Bridgemate Support Center

INFO: Speicherort der .log Dateien

Zuletzt aktualisiert: Jun 24, 2015 02:55PM CEST

Übersicht

Die Bridgemate Control Software führt über vielfältige Aktivitäten und Ereignisse in dem Programm Buch und speichert diese Informationen in .log Dateien. Dieser Artikel erklärt, wie man den Speicherort selber bestimmen kann und wie man die .log Dateien auf Ihrem Rechner finden kann.

 

Die Arten der .log Dateien

Die Bridgemate Control Software hält verschiedene .log Dateien vor; sie alle haben die Dateikennung .log und sind reine Textdateien. Die folgenden .log Dateien sind verfügbar:

  • BmproLog.log : führt Buch über alle allgemeinen Aktivitäten wie das Starten und Beenden des Programms, das Starten von Turnieren, die Bridgemate Aktivitäten (Scores, Spielernummern, An- / Abmelden), etc.
  • Errlog.log : führt Buch über alle Fehler, deren das Programm Gewahr wurde.
  • AppLog.log : führt Buch über alle Aktivitäten der Bridgemate App.
  • USBComErr.log : führt Buch über USB Verbindungen, wenn der USB Server zwar erkannt wurde, aber keine ordnungsgemäße Verbindung hergestellt werden konnte.

Bestimmen des Speicherorts für die .log Dateien

Der Speicherort der .log Dateien kann im Menü Tools -> Optionen --> Allgemein im Reiter Datei-Verzeichnisse eingestellt werden.



Die Standard-Einstellung ist das Benutzer AppData-Verzeichnis. Wenn Sie es vorziehen, die .log Dateien an einer anderen Stelle zu speichern, wählen Sie Anderes Verzeichnis und klicken Sie auf Ordner auswählen, um einen anderes Verzeichnis als Speicherort auszuwählen. Es wird vorgeschlagen, nicht das BMPro.exe Programm-Verzeichnis zu verwenden, es sei denn, Sie haben das Programm außerhalb des "Programme"-Verzeichnisses installiert.
 

Anmerkung

Wenn Sie den Speicherort für die .log Dateien ändern, werden die vorhandenen Dateien nicht an den neuen Speicherort transferiert. Die alten Dateien verbleiben dort und wenn an dem neuen Speicherort keine .log Dateien vorhanden sind, werden neue .log Dateien erzeugt. Sie können die .log Dateien per Hand von dem alten zum neuen Speicherort kopieren, um vergangene und zukünftige .log Einträge zusammen in einer einzigen Datei zu behalten. Wenn am neuen Speicherort bereits eine .log Datei vorhanden ist (oder Sie die alte .log Datei zum neuen Speicherort kopiert haben), werden zukünftige .log Einträge in dieser Datei am Ende angehängt.

 

Auffinden der .log Dateien auf Ihrem Rechner

Der Speicherort der .log Dateien kann mit Hilfe des Windows Explorers auf Ihrem Rechner ausfindig gemacht werden. Im Falle, dass der Speicherort auf das BMPro.exe Programm Verzeichnis gesetzt ist und die Bridgemate Control Software im "Programme" Verzeichnis Ihres Windows Vista / 7 / 8 / 10 Betriebssystems installiert ist, werden sich die .log Dateien vermutlich nicht im Programm Verzeichnis befinden, weil die Einstellungen von Microsoft Windows ein Schreiben in dieses Verzeichnis verhindern. In diesem Fall werden alle Schreibversuche in dem sog. Virtualstore Verzeichnis, welches das Programme Verzeichnis emuliert, ausgeführt. Um dieses Verzeichnis zu lokalisieren, öffnen Sie den Windows Explorer und gehen Sie zum Benutzer Verzeichnis des aktuellen Benutzers. Im Allgemeinen ist dies C:\Benutzer\<Ihr_Benutzername>.



In Ihrem Benutzer Verzeichnis befindet sich das Verzeichnis AppData. Wenn Sie dieses Verzeichnis nicht sehen können, müssen Sie zunächst Ihre versteckten Dateien und Verzeichnisse sichtbar machen. Dazu gehen Sie z. B. in das Menü Organisieren -> Verzeichnis und Such Optionen. In dem sich öffnenden Fenster klicken Sie auf den Reiter Ansicht.



Wählen Sie Versteckte Dateien und Vereichnisse zeigen aus und klicken Sie auf OK. Das AppData Verzeichnis wird nun sichtbar sein. Doppelklicken Sie auf AppData, und danach auf Local --> VirtualStore --> Program files (x86) --> Bridgemate Pro. Die .log Dateien sind an dieser Stelle gespeichert.

Für den Fall, dass das Verzeichnis direkt auf Benutzer AppData-Verzeichnis eingestellt ist, folgen Sie den o. a. Anweisungen, um in Ihr AppData Verzeichnis zu kommen und doppelklicken Sie auf Local -> BridgeMate Control -> Logs, um Zugang zu Ihren .log Dateien zu erhalten.


Zusätzliche Informationen

Es sind keine zusätzlichen Informationen für diesen Artikel verfügbar.


Siehe auch

Es sind keine weiteren Verweise zu diesem Artikel verfügbar.


Update Entwicklung

19.12.2014 - Artikel veröffentlicht
24.06.2015 - Informationen für BCS 3.1.2 aktualisiert

Did you find this article useful?
Share this article Twitter share Facebook share
http://assets3.desk.com/
false
desk
Laden
Sekunden her
eine Minute her
Minuten her
eine Stunde her
Stunden her
einen Tag her
Tage her
über
false
Ungültige Zeichen gefunden
/customer/de/portal/articles/autocomplete