Bridgemate Support Center

INFO: Location of log files

Last Updated: Jun 24, 2015 02:55PM CEST

Summary

Bridgemate Control Software keeps track of various activities and events in the program and stores this information in log files. This article explains how to set the location of the log files and to find the log files on your computer.

 

Type of log files

Bridgemate Control Software maintains various log files which all have the extension .log and are plain text files. The following log files are available:

  • BmproLog.log : keeps a log of all general activities like opening/closing the program, starting games, Bridgemate activity (scores, player numbers, log on/off), etc.
  • ErrLog.log : keeps a log of all errors tracked by the program.
  • AppLog.log : keeps a log of all Bridgemate app communication
  • USBComErr.log : keeps a log of USB connectivity when the USB server is detected but no proper connection can be established.
 

Setting log file location

The location of the log files can be configured in menu Tools -> Options --> General --> tab File locations.



Default location is User appdata folder. If you prefer to save the log files in another location, select Other folder and click Select folder to choose the new folder location. It is advised not to use the Bmpro.exe program folder, unless you have installed the program in another folder than the "Program files" folder.
 

Note

When you change the log file location, the existing files are not transferred to the new location. The old files will remain, and if no log files exist at the new location, a new log file will be created. You may copy the log files from the old location to the new location manually to keep past and future log entries together in one file. If a log file already exists (or you have copied the old log file to the new location), future log entries will be appended to this file.

 

Locating the log files on your computer

The log files can be located on your computer by browsing to the set folder location using Windows Explorer. In case the location is set to BMPro.exe program folder and Bridgemate Control Software is installed in the "Program files" folder of your Windows Vista/7/8/10 operating system, the log files may not exist in the program folder due to restrictions set by Microsoft Windows to write to this folder. In that case, the folders are written in a so-called Virtualstore folder which emulates writing to the Program files folder. To locate this folder, open Windows Explorer, and go to the user folder of the current Windows user. Commonly, this will be located at C:\Users\<your_username>.



In your user folder, there is a folder AppData. If this folder is not visible, you need first to make hidden files and folders visible. Go to menu Organize --> Folder and search options, the Folder Options window appears, click on tab View.



Select Show hidden files, folders, and drives and press OK. The AppData folder will now appear. Double click on AppData, and next double-click on Local --> VirtualStore --> Program files (x86) --> Bridgemate Pro. The log files are stored in this location.

In case the location is set to User appdata folder, follow above instructions to browse to the Appdata folder, then double click on Local --> BridgeMate Control --> Logs to access the log files.

 

Additional information

There is no additional information available for this article.

 

See also

No further references available for this article.

 

Update history

19-12-2014 - Article published
24-06-2015 - Infomation updated for BCS 3.1.2

 

 

Did you find this article useful?
Share this article Twitter share Facebook share

Contact Us


http://assets2.desk.com/
false
desk
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete